• 偏光显微镜摄像头测量软件imageview文件-保存详解
  • 6.4 保存     Ctrl+S
    选择文件>保存命令在不关闭当前图像的情况下将变动的结果存储到磁盘文件中,如果当前文件是未命名文件,则会弹出对话框让你指定适当的文件名和存储路径。只要你对图像进行了改动,则在关闭程序或者关闭这个图像的时候,都会询问你是否要保存变动,如果选择不保存,则自上一次保存后所做的所有变动都将被丢弃。
    如果图像窗口的标题是以数字表示的如001,002,003等,显测软件会自动弹出文件>另存为… 对话框。
    注意:a)文件>保存命令将窗口所有的内容保存,即使在窗口中存在定义的AOI (兴趣区域);b)文件>保存命令在文件没有改变或改变已经保存以后,会置灰。
    6.5 另存为…
    选择文件>保存为…命令可以将当前窗口的内容用指定的文件格式保存起来。在文件>保存为…命令结束以后,图像窗口会同新的文件以及新的文件格式关联在一起(图像窗口的标题栏会显示新保存文件的新文件名)。显测软件支持的文件保存格式主要有:
    文件名:输入你想要保存的文件名字,或者通过浏览来指定;
    保存类型:在下拉列表框中指定你想要保存的文件类型,也可以通过此方法将一种格式的文件转换为另一种格式。显测软件 支持的存贮格式为:
     

    1.jpg

    Window Bitmap(*.bmp,*.dib,*.rle)
    JPEG(*.jpg,*.jpeg,*.jpe,*.jif,*.jfif)
    Portable Network Graphics(*.png)
    Tag Image File Format(*.tif, *.tiff)
    Compuserve GIF (*.gif) :PCX(*.pcx)
    Targa(*.tga)
    JBIG(*.jbg)
    显测软件 File Type(*.tft)
    选项:点击选项按键可设置格式保存中要用到的各种参数,分述如下:
    6.5.1 JPEG文件保存选项
    对JPEG(*.jpg,*.jpeg,*.jpe,*.jif,*.jfif),选项内容见下图,主要有:
    图像质量:利用滑动条指定保存质量(0--100),缺省值为75;
    累进传输:选与不选,缺省为不选;
    优化Huffman编码:选与不选,缺省为不选;
    光滑:取值为0-100,缺省值为0;
    保存这些设置作为缺省值:下一次保存时,将采用这一次值作为缺省值,缺省为不选。
     

    1.jpg

    6.5.2 PNG文件保存选项
    对Portable Network Graphics(*.png),选项内容有:
     

    1.jpg

    交错:是否进行交错编码;缺省为不选;
    保存这些设置作为缺省值:下一次保存时,将采用这一次选项作为默认值,缺省为不选。
    6.5.3 TGA文件保存选项
    对Tag Image File Format(*.tif, *.tiff),选项内容有:
    追加页:是否以页的形式进行追加,即进行多页存贮;缺省为不选;
    压缩:TIFF 格式可选择不同的压缩方式;缺省为LZW(default);
    图像质量:根据压缩方式,利用滑动条指定保存质量(0--100),缺省值为75;
    重置:设置为程序指定的值;
    保存这些设置作为缺省值:下一次保存时,将采用这一次值作为缺省值,缺省为不选。
     

    1.jpg

    6.5.4 其他文件格式保存选项
    对WindowBitmap(*.bmp,*.dib,*.rle),Compuserve GIF (*.gif),PCX(*.pcx),Targa(*.tga),JBIG(*.jbg),显测软件 File Type(*.sft),选项按键呈灰色,表示这些格式不存在选项设置。
    注意:a)编码以及压缩的细节可参照相关的文献。上述学术名词可以以参考相关的图像处理以及图像压缩书籍或网络;b)文件保存的目录可以还原以供将来使用。为保证下一次显测软件打开的时候,仍然定位的当前用过的目录,选择选项>首选项…命令,单击杂项,在隐私项中复选上打开文件时还原文件路径如上图所示:
     

    1.jpg

    6.6 批量保存…      CTRL+Q
    当捕获了很多文件并希望保存的时候,选择文件>保存为…命令可以完成保存操作。但这一保存过程相当费时费力。文件>批量保存… 命令其过程同运行文件>保存为…命令是一样的,但是用户不需要再一个个输入保存文件名,其文件名按照一定的规则在批量保存对话框指定,并持续运用直到所有文件保存完为止。
    文件>批量保存…命令运行步骤如下:
    1. 启动相机;
    2. 捕获图像;
    3. 选择文件>批量保存… 命令弹出批量保存对话框,批量对话框的各项介绍如下:
     

    1.jpg

    目录: 输入捕获图像希望保存的驱动同目录。可以直接输入也可以利用浏览按键 直接标准的浏览文件夹对话框中选取;
    名字格式: 名字捕获时的year,month,date,hour,minute和second或nnnn序号来自动生成或。如果1秒钟内可以保存很多文件,则会自动在前面选定的名字格式后面加上(x),这时是一个数字以避免可能出现的相同的文件名;如果选定的名字格式是nnnn(序号),则不再需要(x)后缀;
    文件前缀: 在生成一系列图像的时候,根本喜好还可输入名字格式的“文件前缀”以同名字格式组合成一复合的文件名;
    文件类型: 在文件类型列表框中,可选择批量保存的文件类型(可以是BMP, JPG, PNG, TIF)。 单击文件类型右边的选项键以设置不同的文件编码参数(对BMP格式,选项键无效,有关文件保存格式的选项内容,可参阅文件>保存为…菜单);
    样式: 最后确认的文件名样式会在这里显示供参考。
    4. 当所有的选择或设置都确认以后,单击确定键即可开始批量保存过程,单击取消以取消文件>批量保存…命令并返回到应用程序原来状态。
    注意:a)在文件文件>批量保存…命令过程中,图像选项卡的标题会更换成批量保存对话框按一定的规则确定的文件名;b)当所有更改过的文件都保存了以后,文件>批量保存…菜单无效。只要有一个文件更改过,这一菜单就会使能。
     

     

     

     

     

  • 上一篇:分析偏光显微镜在金相分析中的三种应用
  • 下一篇:偏光显微镜摄像头测量软件old-sg文件-保存详解